Website Not Accessible
Incident Report for GlobalGiving
Resolved
Internet connectivity has been restored and the site is accessible.
Posted almost 2 years ago. Dec 08, 2016 - 14:13 EST
Identified
Our internet service provider is experiencing an outage which is impacting the availability of our servers. We are working with them to investigate and resolve the issue.
Posted almost 2 years ago. Dec 08, 2016 - 13:48 EST