Cart & Checkout Not Loading
Incident Report for GlobalGiving
Resolved
Our payment processor has indicated that the problem is resolved, and we are seeing no more problems with our checkout flow.

If you experience anymore problems, please check back here, or contact us.
Posted about 2 years ago. Nov 19, 2016 - 11:11 EST
Monitoring
Our payment processor is currently experiencing a major outage. Due to this, and the way we integrate with them, our cart pages are failing to load for some users, and super slow to load for others.

We apologize for the inconvenience, and are monitoring the issue closely with our payment processor. We will update this page when there is more information.

If you are trying to make a donation on GlobalGiving, please try again a little later today. Thank you.
Posted about 2 years ago. Nov 19, 2016 - 10:52 EST