Website Not Responding
Incident Report for GlobalGiving
Resolved
Everything appears to be fully operational again. Sorry for the inconvenience.
Posted 13 days ago. Nov 06, 2018 - 23:40 EST
Identified
GlobalGiving.org is not responding to requests at this time. Our team is working to resolve this situation as quickly as possible
Posted 13 days ago. Nov 06, 2018 - 22:35 EST
This incident affected: API, Project Entry, GlobalGiving.org, Credit Card Processing, and PayPal Processing.