GlobalGiving.org slow to respond, timing out
Incident Report for GlobalGiving
Resolved
We have put some changes into place to better handle the traffic coming in for the Little by Little campaign, which have resolved the issues on the rest of the site. If you have any further problems, please email customerservice@globalgiving.org
Posted 3 months ago. Apr 08, 2019 - 20:49 EDT
Update
We have taken some corrective actions, which have helped. We are continuing to investigate the root cause and put additional fixes into place. Sorry for the inconvenience.
Posted 3 months ago. Apr 08, 2019 - 17:38 EDT
Investigating
We have received reports that some parts of our site are loading very slowly or failing to load all together. We are looking into the issue and seeking to resolve it as quickly as possible.
Posted 3 months ago. Apr 08, 2019 - 15:10 EDT
This incident affected: API, Project Entry, and GlobalGiving.org.