Checkout Not Working
Incident Report for GlobalGiving
Resolved
A fix has been deployed and we have verified that checkout is working now. Thank you for your patience.
Posted Oct 06, 2023 - 11:40 EDT
Identified
We have identified the root cause, and are working to get a fix deployed
Posted Oct 06, 2023 - 10:35 EDT
Investigating
We are investigating an issue with checkout not allowing users to complete donations on GlobalGiving.org
Posted Oct 06, 2023 - 10:34 EDT
This incident affected: GlobalGiving.org.