PayPal Checkouts Failing
Incident Report for GlobalGiving
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 28, 2018 - 14:25 EDT
Update
We have resolved the underlying problem with our PayPal integration and donations are working.
Posted about 1 year ago. Aug 28, 2018 - 14:24 EDT
Investigating
All donations made on GlobalGiving.org using PayPal payments are not working right now. Recurring donations that were previously setup with PayPal are functioning correctly. We are investigating the root cause.
Posted about 1 year ago. Aug 28, 2018 - 12:24 EDT
This incident affected: PayPal Processing.