Slow Page Loads
Incident Report for GlobalGiving
Resolved
Everything appears to be operating normally again.
Posted 3 months ago. Apr 09, 2019 - 11:49 EDT
Identified
Some pages on GlobalGiving.org are slow to load right now. ˇWe have identified the problem and are deploying a fix for it right now. Thank you for your understanding
Posted 3 months ago. Apr 09, 2019 - 10:37 EDT
This incident affected: Project Entry and GlobalGiving.org.