Disruption to GlobalGiving website and services

Incident Report for GlobalGiving

Resolved

We are not seeing any more errors related to this incident. Thank you for your patience.
Posted Jul 02, 2025 - 11:22 EDT

Monitoring

We have finished rolling out a fix and believe that we have caught all of the problems. We are monitoring the situation to ensure that everything is stable and functional.
Posted Jul 02, 2025 - 10:50 EDT

Identified

We have identified the problem and are rolling out a fix
Posted Jul 02, 2025 - 10:23 EDT

Update

We are continuing to investigate this issue.
Posted Jul 02, 2025 - 09:59 EDT

Investigating

We are aware of an issue that is causing large parts of the GlobalGiving website to respond with an error. We are investigating
Posted Jul 02, 2025 - 09:58 EDT
This incident affected: GlobalGiving.org, API, Project Entry, Credit Card Processing, and PayPal Processing.