Disruption with some GlobalGiving services

Incident Report for GlobalGiving

Resolved

We have resolved the issue. Emails are being delivered, response times are back to normal and the rate of errors has gone back to expected levels. Thank you for your patience.
Posted Jul 03, 2025 - 13:28 EDT

Identified

We have identified some additional disruptions from yesterdays incident and are working to resolve them now. GlobalGiving website visitors may notice occasional slow response times, intermittent errors, or delayed email delivery. We are working to resolve this as quickly as possible.
Posted Jul 03, 2025 - 10:52 EDT
This incident affected: GlobalGiving.org, API, and Project Entry.