High Website Error Rates
Incident Report for GlobalGiving
Resolved
The issue has been resolved.
Posted Oct 16, 2021 - 14:34 EDT
Update
We are continuing to investigate this issue.
Posted Oct 16, 2021 - 14:33 EDT
Investigating
We are investigating higher than normal error rates on requests to GlobalGiving.org. If you get an "Oops" when using the site, please try again.
Posted Oct 16, 2021 - 10:55 EDT
This incident affected: GlobalGiving.org and Project Entry.